Digital Camera Software
1.6 Installation Problem
JBear17-Jul-2012/4:36:15+2:00
Hi, I have the following error come up (in Notebook) when trying to open the program...

** Script Error: to-rebol-file expected path argument of type: file string
** Where: context
** Near: path-app-folder: join dirize to-rebol-file get-reg
** Press enter to quit...

Running Vista Home Basic 32 bit. Thank you
 
GreG29-Jul-2012/16:16:24+2:00
Thanks for reporting this, we'll have a check at Namexif 1.6 on this. We can't reproduce this error for now.
 
sjl@zepler.org17-Nov-2012/13:54:16+1:00
I am also having this problem on Windows 7 64 bit. However Namexif used to work fine. I think perhaps a recent windows update has changed something.

Below is an email I sent to feedback@digicamsoft.com but received no reply. The email was sent 29/10/2012 so if it is a windows update it was applied in the month or 2 before that - I generally keep up to date with windows updates.


Hi,

My installation of Namexif 1.6 has stopped working on Windows 7 64 bit. It was working a few months ago but isn't now. I get the following in a REBOL/View window:

** Script Error: to-rebol-file expected path argument of type: file string
** Where: context
** Near: path-app-folder: join dirize to-rebol-file get-reg
** Press enter to quit...

I suspect a windows update has changed something seeing as it used to work. I am up to date on windows updates.

Regards,
Simon
 
GreG17-Nov-2012/22:19:46+1:00
Thanks for reporting this.

I tried again on my Windows 7 64 bit and can't reproduce this issue.
However, based on the error message provided, I'll provide a fix. I keep you posted on this thread.
Thanks!
 
sjl@zepler.org5-Dec-2012/15:54:21+1:00
Hi,

I'm a software engineer (used to work for Canon actually) and I know this is probably not high priority for you since this is free software that you provide but could you take a look at this problem soon?

Thanks,
Simon
 
GreG5-Dec-2012/20:49:29+1:00
Hi Simon,
I again appreciate your feedback, I'll do my best to fix this bug by mid december. Please check in 10 days at the latest.
Thanks
 
sjl@zepler.org6-Dec-2012/11:15:49+1:00
Thanks, I appreciate it.
 
GreG20-Dec-2012/15:56:39+1:00
Not forgotten, just a bunch of unexpected things to do. Will fix it very soon.
 
sjl@zepler.org11-Jan-2013/12:32:21+1:00
Hi Greg, just giving you another prod Simon
 
GreG13-Jan-2013/16:19:21+1:00
Hi Simon,
Currently checking at this.
First thing is: I don't reproduce the issue on a Windows 7 Enterprise SP1 64 bits.

What Namexif tries to do is to read the Application Folder in order to write and remember settings.
Could you check if you have any value via regedit for:
Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders" "AppData"

Worst case is to write settings where Namexif is located but this might trigger Windows alerts, hence not working.
 
sjl@zepler.org29-Jan-2013/12:39:26+1:00
For anyone reading this, Greg did fix this for me. Thanks Greg, Simon
 
GreG31-Jan-2013/21:25:26+1:00
Thanks Simon
I still have to make it available to everyone.
 

Login required to Post. Click Login button to proceed.


www.digicamsoft.com